Search results for
pleo
(10518)
Star Rating
Categories
Categories(2)
Sellers(504)
Solutions(0)
Discussions(6)
Articles(6)
Advanced FiltersClear Filter
Star Rating
Categories
The next elements are filters and will change the displayed results once they are selected.

AI-Generated Results

Product Description

We empower organizations to operate efficiently and accelerate success by aligning people with technology.

Product Description

Gain an insight into what truly drives productivity and performance of your teams and organizations. Get numeric answers to the following questions using the data you already possess: - How to increase the performance and profitability of my teams / departments? - What attrition can I expect and what to do about it? (especially in light of the Great Resignation) - What is the true sentiment across the organization? - Are people actually engaged when in video conference calls? - How psyc

Product Description

UbiHRM is an integrated human resource management software designed to help manage people and processes.

Product Description

MyDisabilityJobs is a tool that allows inclusive companies to recruit people with disabilities.

Product Description

Sales Prophet provides sales automation and marketing automation capabilities that is integrated with a large database of over 80 million B2B contact records. Sales Prophet offers unlimited access to their B2B data which can be used to send text-based sales sequences to support our lead generation efforts or HTML-based emails to support your marketing departments demand generation efforts. At the heart of Sales Prophet is a very robust email platform that offers one clink integration with G-s

Product Description

Hproxy.com - Proxy servers are made for delivering different experience depending on your needs Private Socks5 & HTTPs proxies for any purpose. We provide high-quality private Residential and Mobile 4G/5G/LTE proxies. Our proxies work well with: online games; social networks; web scraping; sneaker websites; online marketplaces; crypto; and other purposes. Also, we have the function of using API documentation. Hproxy.com also a lot of useful features, such as an affiliate program for each use

Product Description

Peekator is the fastest-evolving, friendliest consumer research platform. We are a team of young and ambitious people who started this journey in 2018. Since the beginning of Peekator, we have tested different products and services in the industry, which has helped us perfect our current product - the friendliest research platform for insight and marketing teams. Here’s how our platform works in three simple steps: 1. You have questions - We’ll show you around our platform and help y

Product Description

Attrock is a Digital Marketing Company committed to providing competitive, high-quality Digital Marketing services. Our team works closely with your people to come up with a Digital strategy that fits your needs, ultimately helping your business to get on top. We offer a full range of digital marketing and consulting services including SEO, ASO, Conversion Rate Optimization, Content Marketing, Influencer marketing, and more. At Attrock, we make sure to provide hands-on guidance at every step of

Product Description

Our product family is now called Bloom Intranet, and it comes in two flavors: Bloom Hub and Bloom Elements. About Bloom Hub Bloom Hub is your digital happy place: a fully customizable, role-based dashboard that turns Microsoft 365 into a workspace that actually works for you. More than a collection of smart widgets, it's a powerful platform built on Microsoft SharePoint, giving every user a personalized, secure, and engaging starting point for their day. From IT to HR to Internal Communications,

Product Description

Muck Rack for Journalists is a comprehensive, free platform designed to empower journalists by providing tools to manage their online presence, monitor news, and connect with peers. It enables journalists to create and showcase portfolios, track their published work, and stay informed about industry trends and media movements. By offering a centralized hub for their professional activities, Muck Rack enhances journalists' ability to engage with their audience and streamline their workflow. Key

Product Description

Genesis HR Solutions offers a complete range of solutions for companies small to mid-size to manage human resources, control costs, retain good people, cope with regulation and achieve solid growth. MyGenesisHR online portal provides industry-leading services typically available to employees and managers at major companies.

Product Description

It is a field sales team management application by which companies can manage their field sales force through GPS location. This app enables the team to create new distributors, visit nearby parties, making visit revisits, take orders, get performance insights and many others. The captured data will plot dashboards and also reports in the Admin Portals which helps the management to take data driven analysis.

Product Description

Smartocto is all about editorial analytics and content intelligence. We want to help storytellers create the best possible content, catered to their target audience and business goals. We do this by providing advanced metrics and analytics, but presented in the most actionable, attractive and comprehensible way possible. After all, writers are not data people, but they can greatly benefit from using data, so our goal is to make it as accessible as possible.

Product Description

e-Serve Shiksha is a service provider of the academic management module and education management Software.

Product Description

Agent Anything is a platform that allow people and companies post small jobs, tasks, and errands to a skilled but student workforce.

Product Description

TekSIP is a SIP Registrar and SIP Proxy for Windows. TekSIP supports UDP, TCP, TLS and WebSocket (IPv4 & IPv6) transports. TLS and Secure WebSocket are supported in only commercial editions. TekSIP is tested on Microsoft Windows Vista, Windows 7/8/10/11 and Windows 2008-2022 server. TekSIP can be deployed as a signaling server for WebRTC based SIP phones. TekSIP complies with RFC 3261, RFC 3263, RFC 3311, RFC 3581 and RFC 3891. It supports NAT traversal and ENUM. Please see technical detail

Product Description

W. Mount Designs specializes in creating high-quality, custom-designed wall mounts tailored to enhance both the functionality and aesthetic appeal of various spaces. Their products are crafted with precision, ensuring durability and a seamless integration into any interior design. Key Features and Functionality: - Custom Design: Each wall mount is uniquely designed to meet specific client requirements, ensuring a perfect fit for the intended space. - High-Quality Materials: Utilizing premium

Product Description

Crowdicity provides a management software that empowers organisations to harness the idea and creativity of their people to discover new perspectives, insights and opportunities.

Product Description

Antidote is a digital health company on a mission to accelerate the breakthroughs of new treatments by bridging the gap between medical research and the people who need it.

Product Description

Palm is a business identity network and API platform for verifying businesses and the people behind them. Vertical SaaS platforms, fintechs, and SMB-focused partners use Palm to run KYB and KYC at onboarding, monitor customers for compliance changes, and file formations and registrations — all through one API. Palm connects to Secretary of State registries across all 50 states and the IRS, covering 125M+ business records and 35M+ active US businesses, with 3B+ attributes refreshed every six day